Maintenance on Internet and Mobile Banking

Incident Report for Alex Bank

Resolved

This incident has been resolved.
Posted Mar 19, 2023 - 18:26 AEST

Update

We are continuing to investigate this issue.
Posted Mar 19, 2023 - 18:25 AEST

Investigating

We will be undergoing maintenance on our Internet and Mobile banking systems and will be back online soon. Apologies for any inconvenience.
Posted Mar 19, 2023 - 12:20 AEST
This incident affected: Alex Online (Internet Banking / Alex Mobile App).